const regex = /^\[[^\]]+\][^\n]+(?:\n[^\[\n][^\n]+)*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\[[^\\]]+\\][^\\n]+(?:\\n[^\\[\\n][^\\n]+)*', 'gm')
const str = `[08-Jul-2018 08:12:04 UTC] PHP Fatal error: on line 44
[08-Jul-2018 08:22:22 UTC] PHP Fatal error: in ...:37
Stack trace:
#0 C:\\xampp\\htdocs\\wordpress\\wp-content\\themes\\news_theme\\index.php(37):
PDOStatement->execute()
#1 C:\\xampp\\htdocs\\wordpress\\wp-includes\\template-loader.php(74):
include('C:\\\\xampp\\\\htdocs...')
thrown in ... on line 37
[08-Jul-2018 08:12:45 UTC] PHP Fatal error: on line 155
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}