use strict;
my $str = '[08-Jul-2018 08:12:04 UTC] PHP Fatal error: on line 44
[08-Jul-2018 08:22:22 UTC] PHP Fatal error: in ...:37
Stack trace:
#0 C:\\xampp\\htdocs\\wordpress\\wp-content\\themes\\news_theme\\index.php(37):
PDOStatement->execute()
#1 C:\\xampp\\htdocs\\wordpress\\wp-includes\\template-loader.php(74):
include(\'C:\\\\xampp\\\\htdocs...\')
thrown in ... on line 37
[08-Jul-2018 08:12:45 UTC] PHP Fatal error: on line 155
';
my $regex = qr/^\[[^\]]+\][^\n]+(?:\n[^\[\n][^\n]+)*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}