using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",[5-9]\d+$";
string input = @"38499,2
38501,3
38502,5
38504,4
38505,4
38506,256
38508,1
38509,91
38510,4123
38511,5123
38512,5";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}