#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)>([^<>]*\S)<"
Local $sString = "<tr>" & @CRLF & _
                "	<td class="no-min-width   " style="" width="45" data-col="0">" & @CRLF & _
                "		<a href="/[ステージオブマジック]島村卯月">" & @CRLF & _
                "			<img src="https://cdn.img-conv.gamerch.com/img.gamerch.com/imascg-slstage-wiki/wikidb_thumbnail/338316/individual_200.jpg?d=20190419162924&q=20" class="lazy ui_thumbnail" data-original="https://cdn.img-conv.gamerch.com/img.gamerch.com/imascg-slstage-wiki/wikidb_thumbnail/338316/individual_200.jpg?d=20190419162924&q=20" alt="[ステージオブマジック]島村卯月">		</a>" & @CRLF & _
                "	</td>" & @CRLF & _
                "	<td class="   " style="" data-col="1">" & @CRLF & _
                "		<a href="/[ステージオブマジック]島村卯月">" & @CRLF & _
                "			<span data-jscol_sort="[ステージオブマジック]島村卯月">[ステージオブマジック]島村卯月</span>" & @CRLF & _
                "		</a>" & @CRLF & _
                "	</td>" & @CRLF & _
                "	<td class="   " style="" data-col="2">" & @CRLF & _
                "		<span data-jscol_sort="島村卯月">" & @CRLF & _
                "			<a href="https://imascg-slstage-wiki.gamerch.com/%E5%B3%B6%E6%9D%91%E5%8D%AF%E6%9C%88" class="ui_page_match" title="島村卯月">" & @CRLF & _
                "				島村卯月" & @CRLF & _
                "			</a>" & @CRLF & _
                "		</span>" & @CRLF & _
                "	</td>" & @CRLF & _
                "	<td class="   " style="" data-col="3">" & @CRLF & _
                "		<span data-jscol_sort="キュート">キュート</span>" & @CRLF & _
                "	</td>" & @CRLF & _
                "	<td class="   " style="" data-col="4">" & @CRLF & _
                "	</td>" & @CRLF & _
                "</tr>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
    _ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")