using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"static\s+abc_p\s+ABC_P\[\s*\]\s*=\s*\{(\n((?:[^{]*\{\n([^}]*)\}\,\n\s*\}\,\n)))[^;]*";
string input = @"static abc_p ABC_P[] = {
/* Netz I */
{
N1
N1
N1
0,
{
Flg1
0,
Flg2
0,
Flg3
0,
Flg4
0,
},
},
/* Netz E1 */
{
N2
N2
N2
0,
{
Flg1
0,
Flg2
0,
Flg3
0,
Flg4
0,
},
},
};
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}