package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)static\s+abc_p\s+ABC_P\[\s*\]\s*=\s*\{(\n((?:[^{]*\{\n([^}]*)\}\,\n\s*\}\,\n)))[^;]*`)
var str = `static abc_p ABC_P[] = {
/* Netz I */
{
N1
N1
N1
0,
{
Flg1
0,
Flg2
0,
Flg3
0,
Flg4
0,
},
},
/* Netz E1 */
{
N2
N2
N2
0,
{
Flg1
0,
Flg2
0,
Flg3
0,
Flg4
0,
},
},
};
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}