use strict;
my $str = 'static abc_p ABC_P[] = {
/* Netz I */
{
N1
N1
N1
0,
{
Flg1
0,
Flg2
0,
Flg3
0,
Flg4
0,
},
},
/* Netz E1 */
{
N2
N2
N2
0,
{
Flg1
0,
Flg2
0,
Flg3
0,
Flg4
0,
},
},
};
';
my $regex = qr/static\s+abc_p\s+ABC_P\[\s*\]\s*=\s*\{(\n((?:[^{]*\{\n([^}]*)\}\,\n\s*\}\,\n)))[^;]*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}