# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([\w-]+): (.+?)\\r\\n(?:([^:]+?)\\r\\n)?"
test_str = ("MIME-Version: 1.0\\r\\n\n"
"x-no-auto-attachment: 1\\r\\n\n"
"Received: by 10.200.36.132; Sun, 5 Feb 2017 01:21:33 -0800 (PST)\\r\\n\n"
"Date: Sun, 5 Feb 2017 01:21:33 -0800\\r\\n\n"
"Message-ID: <IIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIII@mail.gmail.com>\\r\\n\n"
"Subject: =?UTF-8?Q?MMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMM?=\\r\\n\n"
"=?UTF-8?Q?ail?=\\r\\n \\\n"
"From: =?UTF-8?B?VGhlIGZ1Y2sgYXJlIHUgbG9va2luZyBmb3I/?= <noreply@mail.com>\\r\\n\n"
"To: mail mail <mail@mail.com>\\r\\n\n"
"Content-Type: multipart/alternative; boundary=1a3xca651sv561fd321c5xv61sd12\\r\\n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.