using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.{16})(?=.*?\S{3})(?>[A-Za-z][a-z]* ?\b){1,3}$";
string input = @"Should match:
Yaw
yaw
James Bond
Monkey D Luffy
List item
Shouldn't match:
YaW
Two spaces
No no no
JamesBond";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}