// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([1-9]\d*|0) rows returned\.$").unwrap();
let string = "0 rows returned.
1 rows returned.
10 rows returned.
1234 rows returned.
01 rows returned.
00 rows returned.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}