const regex = /(?:height|width):[^;]*;/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:height|width):[^;]*;', 'gm')
const str = `width:100px;height:200px;float:left;`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);