$re = '/(?m)(.*?@\s*\d+)\s*(.*?&.*)/m';
$str = 'moon @ 215466
sun & stars world
the sea 345454
sky @ 464654';
$subst = "$1#$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;