const regex = /^([^\s]+ ?){1,12}(?<!\.)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^\\s]+ ?){1,12}(?<!\\.)$', 'gm')
const str = `Love's Equal On Earth
In a moving "in" and "out of focus" image, what you see is what you want to believe about yourself.
I love the feeling.
I must confess every day for better feeling
REsTsora is a non-profit website of millions of free books, movies, software, music, websites, and more.
Love's Equal. On Earth
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}