$re = '/Ben likes (bananas|mangoes|plums)\./m';
$str = 'Ben likes bananas.
Ben likes mangoes.
Ben likes plums.
Ben likes oranges.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);