import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\d{1,2}[- /]+\\d{1,2}[- /]+\\d{2,4}";
final String string = "im trying to retrieve a date from a string. the problem is that the pattern of this date varies a lot (string comes from an OCR reading). These are the patterns i need to identify:\n\n"
+ " 11/11/1111 (i can get this one already)\n"
+ " 11-11-1111 (i can get this one already)\n"
+ " 11 11 1111 (i can get this one already)\n"
+ " 11- 11- 1111\n"
+ " 11 11 1111\n"
+ " 11-11 1111\n"
+ " 23- 10-17\n"
+ " 9 06- 17\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}