// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b\d{1,2}[- /]+\d{1,2}[- /]+\d{2,4}").unwrap();
let string = "im trying to retrieve a date from a string. the problem is that the pattern of this date varies a lot (string comes from an OCR reading). These are the patterns i need to identify:
11/11/1111 (i can get this one already)
11-11-1111 (i can get this one already)
11 11 1111 (i can get this one already)
11- 11- 1111
11 11 1111
11-11 1111
23- 10-17
9 06- 17
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}