package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)#([\w\W]*?);`)
var str = `#first line of text;
#second line of text;
#third line could easy
be on a new line;
#forth etc;
#this could (#hi,#hi,#hi) also
happen though:));
#so.... any idea;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}