re = /#([\w\W]*?);/m
str = '#first line of text;
#second line of text;
#third line could easy
be on a new line;
#forth etc;
#this could (#hi,#hi,#hi) also
happen though:));
#so.... any idea;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end