re = /((^[a-zA-Z0-9]+)(([_]?)|([.]|[-])?[a-zA-Z0-9]+)*@([a-zA-Z0-9]+)(([_]?)|([.]|[-])?[a-zA-Z0-9]+)*\.[a-zA-Z0-9]+$)/m
str = 'username@email.com
user.name@email.com.gh
user_name@email.edu.com
user-name@email.edu.uni.gh
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end