# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:.+\n)*.*?\bcat\b.*(?:\n.+)*"
test_str = ("Paragraph 1 wepfowfpo\n"
"fww efwf\n\n"
"Paragraph 2 wefwf32321\n"
"!@d r33tcat54, 333!..\n\n"
"Paragraph 3 4t4t022\n"
"-`121231ere3r3cat342232\n"
"$ 4t0g cat rdwd203 \n"
"$$333\n\n"
"Paragraph 4 222cocdo3\n\n"
"Paragraph 5 Cat")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.