re = /(\d\D?){10}\b/m
str = '02-15-87-96-54
1234567890
02-02-024589
023-023-0254'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end