using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\""fileAssetId\"":\"")[a-fA-F0-9-]+?(?=\"")|(?<=\""filename\"":\"").+?(?=\"")";
string input = @"'{""d"":{""__type"":""WikiFileNodeContent:http:\/\/samplesite.com.u\/ns\/business\/wiki"",""author"":null,""description"":null,""fileAssetId"":""034b9317-60d9-45c2-b6d6-0f24b59e1991"",""filename"":""Reports.pdf""},""createdBy"":1531,""createdByUsername"":""John Cash"",""icon"":""\/Assets10.37.5.0\/pix\/16x16\/page_white_acrobat.png"",""id"":3041, ""filename"":""test"", ""inheritedPermissions"":false,""name"":""map"",""permissions"":[23,87,35,49,65],""type"":3,""viewLevel"":2},{""__type"":""WikiNode:http:\/\/samplesite.com.au\/ns\/business\/wiki"",""children"":[],""content""'";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}