import re
regex = re.compile(r"(?<=\"fileAssetId\":\")[a-fA-F0-9-]+?(?=\")|(?<=\"filename\":\").+?(?=\")")
test_str = "'{\"d\":{\"__type\":\"WikiFileNodeContent:http:\\/\\/samplesite.com.u\\/ns\\/business\\/wiki\",\"author\":null,\"description\":null,\"fileAssetId\":\"034b9317-60d9-45c2-b6d6-0f24b59e1991\",\"filename\":\"Reports.pdf\"},\"createdBy\":1531,\"createdByUsername\":\"John Cash\",\"icon\":\"\\/Assets10.37.5.0\\/pix\\/16x16\\/page_white_acrobat.png\",\"id\":3041, \"filename\":\"test\", \"inheritedPermissions\":false,\"name\":\"map\",\"permissions\":[23,87,35,49,65],\"type\":3,\"viewLevel\":2},{\"__type\":\"WikiNode:http:\\/\\/samplesite.com.au\\/ns\\/business\\/wiki\",\"children\":[],\"content\"'"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")