use strict;
my $str = '#include <stdio.h>
int main()
{
printf("Hello, World!");
return 0;
}
public class HelloWorld {
public static void main(String[] args) {
System.out.println("Hello, World!");
}
}
MsgBox, Hello, World!';
my $regex = qr/(?<=^|\b|(?<=\W)(?=\W))\S+?(?=$|\b|(?<=\W)(?=\W))/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}