import Foundation
let pattern = #"<([A-z0-9-_]+)(([^>"]+"[^"]*")*\s*)/>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<div class="bbn-flex-fill">
<div v-if="arrowsPosition.startsWith('top')"
class="bbn-flex bbn-bottom-sspace"
:style="arrowsStyle">
<i v-show="showArrowLeft"
:class="[leftArrowClass, 'bbn-p', 'bbn-lg']"
@click="prev"
:style="{visibility: (currentIndex === 0 && !loop)? 'hidden' : 'visible'}"/>
<i v-show="showArrowRight"
@click="next"
:class="[
rightArrowClass,
'bbn-p',
'bbn-lg'
]"
:style="{visibility: (currentIndex >= items.length - 1) && !loop ? 'hidden' : 'visible'}"/>
</div>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)