$re = '/cig[\s:.]*(\S(?:\s*\S){9})(?!\S)/mi';
$str = '/BENEF/FORNITURA GAS FEB-20 CIG Z9F 27D2198 01762-0000031';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);