$re = '/(?<=<h1 class="entry-title"><a href=").+(?=" )/m';
$str = '<h1 class="entry-title"><a href="CONTEUDO QUE EU QUERO E VARIA SEMPRE" rel="bookmark">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);