use strict;
my $str = 'article-paris-sous-la-neige-de-solferino-aux-tuileries-41499862.html';
my $regex = qr/(\d{4})/(\d{2})/(.*)\.html/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";