$re = '/(\d{4})/(\d{2})/(.*)\.html/m';
$str = 'article-paris-sous-la-neige-de-solferino-aux-tuileries-41499862.html';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;