package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(\bgpa[ :]+)?(\d+(?:\.\d+)?)[/\d. ]{0,6}(?(1)| *gpa\b)`)
var str = `GPA 3.75/4.00
GPA 3.75/4.0
GPA 3.75 /4.0
GPA 3.75 / 4.0
GPA 3.7 / 4 aaa
Major GPA: 3.6/4.0
GPA 3.1
GPA 3
some text GPA 3
3.25/4.0 GPA
some text 3.26 / 4.0 GPA
Minor in Art and Technology - 3.5/4.0 GPA aaaa
Minor in Art and Technology - 3.5 / 4.3 GPA aaaa
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}