import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\bgpa[ :]+)?(\\d+(?:\\.\\d+)?)[/\\d. ]{0,6}(?(1)| *gpa\\b)";
final String string = "GPA 3.75/4.00\n"
+ "GPA 3.75/4.0\n"
+ "GPA 3.75 /4.0\n"
+ "GPA 3.75 / 4.0\n"
+ "GPA 3.7 / 4 aaa\n"
+ "Major GPA: 3.6/4.0\n"
+ "GPA 3.1\n"
+ "GPA 3\n"
+ "some text GPA 3\n"
+ "3.25/4.0 GPA\n"
+ "some text 3.26 / 4.0 GPA\n"
+ "Minor in Art and Technology - 3.5/4.0 GPA aaaa\n"
+ "Minor in Art and Technology - 3.5 / 4.3 GPA aaaa\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}