Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^https:\/\/(?:www\.)?youtube\.com\b
/
mg
Input 1
1
New
https://www.youtube.com/watch?v=AAAAAAAAAAA https://www.youtube.comm/watch?v=AAAAAAAAAA https://youtube.com/watch?v=AAAAAAAAAAA https://youtube.comm/watch?v=AAAAAAAAAAA youtube.com/watch?v=AAAAAAAAAAA www.youtube.com/watch?v=AAAAAAAAAAA https://example.com/redirect?url=https://www.youtube.com/watch?v=AAAAAAAAAAA