import Foundation
let pattern = #"^https:\/\/(?:www\.)?youtube\.com\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://www.youtube.com/watch?v=AAAAAAAAAAA
https://www.youtube.comm/watch?v=AAAAAAAAAA
https://youtube.com/watch?v=AAAAAAAAAAA
https://youtube.comm/watch?v=AAAAAAAAAAA
youtube.com/watch?v=AAAAAAAAAAA
www.youtube.com/watch?v=AAAAAAAAAAA
https://example.com/redirect?url=https://www.youtube.com/watch?v=AAAAAAAAAAA
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)