const regex = /[0-9]{1,2}\. [\w+()=#-]+ [\w+()=#-]+|[0-9]{1,2}\. [\w+()=#-]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9]{1,2}\\. [\\w+()=#-]+ [\\w+()=#-]+|[0-9]{1,2}\\. [\\w+()=#-]+', 'g')
const str = `1. e4 Nf6 2. e5 Nd5 3. d4 d6 4. c4 Nb6 5. f4 dxe5 6. fxe5 Nc6 7. Be3 Bf5 8. Nc3 e6 9. Nf3 Qd7 10. Be2 O-O-O 11. O-O Be7`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}