#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:\[[^][]*]|\([^()]*\)|{[^{}]*})(*SKIP)(*F)|."
Local $sString = "Hello [123] {45} world (67)" & @CRLF & _
"Hello There (8) [9] {0}" & @CRLF & _
"(this]"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)