package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\[[^][]*]|\([^()]*\)|{[^{}]*})(*SKIP)(*F)|.`)
var str = `Hello [123] {45} world (67)
Hello There (8) [9] {0}
(this]`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}