const regex = /(?:\[[^][]*]|\([^()]*\)|{[^{}]*})(*SKIP)(*F)|./gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\[[^][]*]|\\([^()]*\\)|{[^{}]*})(*SKIP)(*F)|.', 'gm')
const str = `Hello [123] {45} world (67)
Hello There (8) [9] {0}
(this]`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);