use strict;
my $str = 'Hello [123] {45} world (67)
Hello There (8) [9] {0}
(this]';
my $regex = qr/(?:\[[^][]*]|\([^()]*\)|{[^{}]*})(*SKIP)(*F)|./mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";