// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\[[^][]*]|\([^()]*\)|{[^{}]*})(*SKIP)(*F)|.").unwrap();
let string = "Hello [123] {45} world (67)
Hello There (8) [9] {0}
(this]";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}