package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)CNPJ\s+[-]\s+(\d+)`)
var str = `CNPJ - 24414873000109`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}