$re = '/CNPJ\s+[-]\s+(\d+)/m';
$str = 'CNPJ - 24414873000109';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);