$re = '/(\d+\.\d+)$/m';
$str = 'Болт с шест.гол. (DIN
933)
0.111 х 5555.55=333.33
НДС 20%
ТОВАР
ПЕРЕДАЧА В КРЕДИТ
КОД СТРАНЫ:555
ДЕКЛАРАЦИЯ:111111/22222/33333
ЕД.ИЗМЕРЕНИЯ:тыс. шт
Болт с шест.гол 2 (DIN
933)
2.222 х 3333.33=7777.77
НДС 20%
ТОВАР
ПЕРЕДАЧА В КРЕДИТ
КОД СТРАНЫ:555
ДЕКЛАРАЦИЯ:111111/22222/33333
ЕД.ИЗМЕРЕНИЯ:тыс. шт';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);