$re = '/\b\d+\b/';
$str = 'http://www.66play.com/Home/share/match/id/39455
http://www.66play.com/match-detail-151951
http://www.66play.com/Home/share/match/id/148853?referral=a0ed8f500e2a12da';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);