package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w)(\w+)`)
var str = `any word whatsoever
ANY WORD WHATSOEVER
aNy WoRd WhAtSoEvEr`
var substitution = "\U$1\E\L$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}