use strict;
my $str = 'GMT+05:30
GMT+5:30
GMT+04:60
GMT+13:50
GMT+00:30
GMT+12:56
GMT+11:59
GMT+12:00
GMT-11:00
GMT+5.30
';
my $regex = qr/^GMT[+-]((0?[0-9]|1[0-1]):([0-5][0-9])|12:00)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}