import re
regex = re.compile(r"Session (Start|Close): (\w{3} \w{3} \d{2} \d{2}:\d{2}:\d{2} \d{4})", flags=re.MULTILINE)
test_str = ("Session Close: Fri Oct 30 21:35:44 1998\n\n"
"Session Start: Fri Oct 30 21:39:05 1998\n"
"*** Now talking in #östersund\n"
"Session Close: Fri Oct 30 21:40:48 1998\n\n"
"Session Start: Fri Oct 30 21:41:02 1998\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")