re = /Session (Start|Close): (\w{3} \w{3} \d{2} \d{2}:\d{2}:\d{2} \d{4})/m
str = 'Session Close: Fri Oct 30 21:35:44 1998
Session Start: Fri Oct 30 21:39:05 1998
*** Now talking in #östersund
Session Close: Fri Oct 30 21:40:48 1998
Session Start: Fri Oct 30 21:41:02 1998
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end