$re = '/(?<=QUESTIONS TO )\d+/';
$str = 'GEOGRAPHY QUESTIONS TO 505 (708)
MATHS QUESTION 606 (891)
Physics QUESTION 709 (821)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);