using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<iframe.*?)(src=)([^ ]*?\"".*?>)(.*?)(<\/iframe>)";
string substitution = @"$1class=""gida-dummy gida-dummy-youtube"" data-src=$3$4$5";
string input = @"Custom Gida Iframe SRC grabbber <iframe width=""560"" height=""315"" src=""https://www.youtube-nocookie.com/embed/JOhiWY7XmoY"" frameborder=""0"" allow=""accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture"" allowfullscreen></iframe>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}