const regex = /(<iframe.*?)(src=)([^ ]*?\".*?>)(.*?)(<\/iframe>)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<iframe.*?)(src=)([^ ]*?\\".*?>)(.*?)(<\\\/iframe>)', '')
const str = `Custom Gida Iframe SRC grabbber <iframe width="560" height="315" src="https://www.youtube-nocookie.com/embed/JOhiWY7XmoY" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>`;
const subst = `$1class="gida-dummy gida-dummy-youtube" data-src=$3$4$5`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);